Service Disruption_San Leandro_ 11/22
Incident Report for Common Networks
Resolved
This incident has been resolved.
Posted Nov 23, 2020 - 15:45 PST
Investigating
There is a known electrical issue at a site that is impacting customers in San Leandro. Electricians have been dispatched and are onsite to resolve. They are estimating a return of service around 5:30pm.
Posted Nov 22, 2020 - 15:06 PST
This incident affected: East Bay Network.