Service Disruption_San Leandro_ 6/1
Incident Report for Common Networks
Resolved
PG&E has restored power and service is returning. We will continue monitor on our end.
Posted Jun 01, 2020 - 13:42 PDT
Investigating
We are currently investigating a service disruption impacting customers in San Leandro.
Posted Jun 01, 2020 - 12:56 PDT
This incident affected: East Bay Network.