Alameda Outage _ 4/18
Incident Report for Common Networks
Resolved
We've identified the cause and power has been restored.
Posted Apr 18, 2020 - 20:24 PDT
Investigating
We are currently investigating an outage impacting Alameda.
Posted Apr 18, 2020 - 20:12 PDT
This incident affected: East Bay Network.