Alameda Power Outage _ 6/7
Incident Report for Common Networks
Resolved
Service has been restored. We will continue to monitor.
Posted Jun 07, 2020 - 17:00 PDT
Investigating
Currently tracking the ongoing power outage in Alameda. As service returns, some customer may see degraded service.
Posted Jun 07, 2020 - 16:42 PDT
This incident affected: East Bay Network.