Alameda Power Outage _ 8/28
Incident Report for Common Networks
Resolved
Alameda Municipal Power has restored service. We will continue to monitor on our end for any residual issues caused by the outage.
Posted Aug 28, 2020 - 15:49 PDT
Identified
We are currently following reports of a power outage from Alameda Municipal Power that may be impacting service for customers on the island. Please do check their status page and social media for updates: https://twitter.com/AlamedaMuniPwr/status/1299451463781949441
Posted Aug 28, 2020 - 14:07 PDT
This incident affected: East Bay Network.