Electrical Maintenance_Santa Clara_8/2
Incident Report for Common Networks
Resolved
This incident has been resolved.
Posted 17 days ago. Aug 02, 2019 - 12:06 PDT
Investigating
There is ongoing electrical maintenance in Santa Clara that may cause service disruptions.
Posted 18 days ago. Aug 02, 2019 - 10:15 PDT
This incident affected: South Bay Network.