Alameda Power Outage _ 9/5
Incident Report for Common Networks
Resolved
This incident has been resolved.
Posted Sep 06, 2020 - 06:24 PDT
Investigating
We are currently following reports of a power outage from Alameda Municipal Power that may be impacting service for customers on the island. Please do check their status page and social media for updates: https://twitter.com/AlamedaMuniPwr/status/1299451463781949441
Posted Sep 05, 2020 - 21:06 PDT
This incident affected: East Bay Network.