East Bay Outage 10/25
Incident Report for Common Networks
Resolved
PG&E has restored power to our network. We will continue monitoring.
Posted Oct 25, 2020 - 18:00 PDT
Update
PG&E has revised their estimate - they are now expecting to restore power by 8 pm
Posted Oct 25, 2020 - 14:54 PDT
Identified
We are currently following reports of a power outage from PG&E that is impacted 25,000 PG&E customers. This power outage is also impacting Common Network's service.

PG&E estimates that service will be restored by 2:30PM PDT
Posted Oct 25, 2020 - 13:21 PDT
This incident affected: East Bay Network.