Alameda Power Outage _ 11/1
Incident Report for Common Networks
Resolved
Alameda Power has restored services to those customers impacted by the outage. If your home is still experiencing issues with connecting to the network, please contact support@common.net.
Posted Nov 01, 2020 - 17:04 PST
Investigating
We've received reports of a known Alameda power outage that might be impacting customers.

https://twitter.com/AlamedaMuniPwr/status/1322925589901189121?s=20

https://www.alamedamp.com/AlertCenter.aspx?AID=Power-Outage-Alert-21
Posted Nov 01, 2020 - 07:45 PST
This incident affected: East Bay Network.