Service Disruption,Santa Clara, South Bay, 7/10
Incident Report for Common Networks
Resolved
This incident has been resolved.
Posted Jul 10, 2020 - 12:22 PDT
Investigating
We are currently investigating a service disruption in Santa Clara.
Posted Jul 10, 2020 - 09:59 PDT
This incident affected: South Bay Network.